백준 5639번 (이진 검색 트리, C++) [BAEKJOON]

이진 검색 트리

https://www.acmicpc.net/problem/5639

시간 제한메모리 제한제출정답맞힌 사람정답 비율
1 초256 MB3544213888982138.260%

문제

이진 검색 트리는 다음과 같은 세 가지 조건을 만족하는 이진 트리이다.

  • 노드의 왼쪽 서브트리에 있는 모든 노드의 키는 노드의 키보다 작다.
  • 노드의 오른쪽 서브트리에 있는 모든 노드의 키는 노드의 키보다 크다.
  • 왼쪽, 오른쪽 서브트리도 이진 검색 트리이다.

전위 순회 (루트-왼쪽-오른쪽)은 루트를 방문하고, 왼쪽 서브트리, 오른쪽 서브 트리를 순서대로 방문하면서 노드의 키를 출력한다.

후위 순회 (왼쪽-오른쪽-루트)는 왼쪽 서브트리, 오른쪽 서브트리, 루트 노드 순서대로 키를 출력한다.

예를 들어, 위의 이진 검색 트리의 전위 순회 결과는 50 30 24 5 28 45 98 52 60 이고, 후위 순회 결과는 5 28 24 45 30 60 52 98 50 이다.

이진 검색 트리를 전위 순회한 결과가 주어졌을 때, 이 트리를 후위 순회한 결과를 구하는 프로그램을 작성하시오.

입력

트리를 전위 순회한 결과가 주어진다.

노드에 들어있는 키의 값은 106보다 작은 양의 정수이다.

모든 값은 한 줄에 하나씩 주어지며, 노드의 수는 10,000개 이하이다.

같은 키를 가지는 노드는 없다.

출력

입력으로 주어진 이진 검색 트리를 후위 순회한 결과를 한 줄에 하나씩 출력한다.

예제 입력 1

50
30
24
5
28
45
98
52
60

예제 출력 1

5
28
24
45
30
60
52
98
50

출처

ICPC > Regionals > Asia Pacific > Thailand > 2011 ACM-ICPC Asia Phuket Regional Programming Contest B번

알고리즘 분류


통과된 코드

#include <iostream>

using namespace std;

struct BinaryNode
{
    int _Num;
    BinaryNode* _Left;
    BinaryNode* _Right;

    BinaryNode(int num)
        : _Num(num), _Left(nullptr), _Right(nullptr)
    {}

    void ArrayBinaryNode(int _n)
    {
        if (_Num > _n) {
            if (_Left == nullptr) _Left = new BinaryNode(_n);
            else _Left->ArrayBinaryNode(_n);
        }
        else {
            if (_Right == nullptr) _Right = new BinaryNode(_n);
            else _Right->ArrayBinaryNode(_n);
        }
    }
};

void PostorderTraverse(BinaryNode& CurrentNode)
{
    if (CurrentNode._Left != nullptr) PostorderTraverse(*CurrentNode._Left);
    if (CurrentNode._Right != nullptr) PostorderTraverse(*CurrentNode._Right);
    cout << CurrentNode._Num << "\n";
}


int main()
{
    ios_base::sync_with_stdio(false);
    cin.tie(NULL);
    cout.tie(NULL);

    int _N;
    cin >> _N;
    BinaryNode _RootNode(_N);
    while (true) {
        cin >> _N;
        if (cin.eof() == true)
            break;
        _RootNode.ArrayBinaryNode(_N);
    }

    PostorderTraverse(_RootNode);

	return 0;
}

“백준 5639번 (이진 검색 트리, C++) [BAEKJOON]”에 대한 1,494개의 생각

  1. https://postheaven.net/andhonakpe/can-cinnamon-supplements-help-lower-cholesterol

    Hey everyone! I’ve been experimenting with different natural supplements, and I wanted to share my experience with Ceylon cinnamon supplements. I started taking them a few months ago to help with general inflammation and blood sugar control, and the results have been pretty positive.

    I had read a lot about the benefits of cinnamon for things like blood sugar management, but what really caught my attention was the difference between Ceylon cinnamon and the more common Cassia cinnamon. Ceylon is sometimes called “true cinnamon” and is said to be a lot gentler, especially if you’re taking it long-term. Since I try to stay away from anything that might put too much stress on my liver, Ceylon seemed like the safer choice.

    Since adding the supplement to my routine, I’ve noticed some subtle but real improvements. My energy levels have evened out a bit, especially after meals, which is great because I used to get those annoying energy crashes in the afternoon. I also feel like it’s helped reduce some inflammation in my joints—I don’t feel as stiff in the mornings anymore.

    I wasn’t expecting overnight results, but it’s been one of those slow, steady improvements that have convinced me it’s worth keeping in my regimen. If anyone’s looking for a natural supplement that’s gentle but effective, I’d say give Ceylon cinnamon supplements a try. Just make sure you’re buying from a reputable brand, as not all cinnamon supplements are created equal!

    Has anyone else here had good results with natural supplements like this? Always curious to hear about other people’s experiences with health and wellness!

  2. https://independent.academia.edu/JoeBecchi

    Hey everyone! I’ve been experimenting with different natural supplements, and I wanted to share my experience with Ceylon cinnamon supplements. I started taking them a few months ago to help with general inflammation and blood sugar control, and the results have been pretty positive.

    I had read a lot about the benefits of cinnamon for things like blood sugar management, but what really caught my attention was the difference between Ceylon cinnamon and the more common Cassia cinnamon. Ceylon is sometimes called “true cinnamon” and is said to be a lot gentler, especially if you’re taking it long-term. Since I try to stay away from anything that might put too much stress on my liver, Ceylon seemed like the safer choice.

    Since adding the supplement to my routine, I’ve noticed some subtle but real improvements. My energy levels have evened out a bit, especially after meals, which is great because I used to get those annoying energy crashes in the afternoon. I also feel like it’s helped reduce some inflammation in my joints—I don’t feel as stiff in the mornings anymore.

    I wasn’t expecting overnight results, but it’s been one of those slow, steady improvements that have convinced me it’s worth keeping in my regimen. If anyone’s looking for a natural supplement that’s gentle but effective, I’d say give Ceylon cinnamon supplements a try. Just make sure you’re buying from a reputable brand, as not all cinnamon supplements are created equal!

    Has anyone else here had good results with natural supplements like this? Always curious to hear about other people’s experiences with health and wellness!

댓글 달기

이메일 주소는 공개되지 않습니다. 필수 필드는 *로 표시됩니다

위로 스크롤