백준 5639번 (이진 검색 트리, C++) [BAEKJOON]

이진 검색 트리

https://www.acmicpc.net/problem/5639

시간 제한메모리 제한제출정답맞힌 사람정답 비율
1 초256 MB3544213888982138.260%

문제

이진 검색 트리는 다음과 같은 세 가지 조건을 만족하는 이진 트리이다.

  • 노드의 왼쪽 서브트리에 있는 모든 노드의 키는 노드의 키보다 작다.
  • 노드의 오른쪽 서브트리에 있는 모든 노드의 키는 노드의 키보다 크다.
  • 왼쪽, 오른쪽 서브트리도 이진 검색 트리이다.

전위 순회 (루트-왼쪽-오른쪽)은 루트를 방문하고, 왼쪽 서브트리, 오른쪽 서브 트리를 순서대로 방문하면서 노드의 키를 출력한다.

후위 순회 (왼쪽-오른쪽-루트)는 왼쪽 서브트리, 오른쪽 서브트리, 루트 노드 순서대로 키를 출력한다.

예를 들어, 위의 이진 검색 트리의 전위 순회 결과는 50 30 24 5 28 45 98 52 60 이고, 후위 순회 결과는 5 28 24 45 30 60 52 98 50 이다.

이진 검색 트리를 전위 순회한 결과가 주어졌을 때, 이 트리를 후위 순회한 결과를 구하는 프로그램을 작성하시오.

입력

트리를 전위 순회한 결과가 주어진다.

노드에 들어있는 키의 값은 106보다 작은 양의 정수이다.

모든 값은 한 줄에 하나씩 주어지며, 노드의 수는 10,000개 이하이다.

같은 키를 가지는 노드는 없다.

출력

입력으로 주어진 이진 검색 트리를 후위 순회한 결과를 한 줄에 하나씩 출력한다.

예제 입력 1

50
30
24
5
28
45
98
52
60

예제 출력 1

5
28
24
45
30
60
52
98
50

출처

ICPC > Regionals > Asia Pacific > Thailand > 2011 ACM-ICPC Asia Phuket Regional Programming Contest B번

알고리즘 분류


통과된 코드

#include <iostream>

using namespace std;

struct BinaryNode
{
    int _Num;
    BinaryNode* _Left;
    BinaryNode* _Right;

    BinaryNode(int num)
        : _Num(num), _Left(nullptr), _Right(nullptr)
    {}

    void ArrayBinaryNode(int _n)
    {
        if (_Num > _n) {
            if (_Left == nullptr) _Left = new BinaryNode(_n);
            else _Left->ArrayBinaryNode(_n);
        }
        else {
            if (_Right == nullptr) _Right = new BinaryNode(_n);
            else _Right->ArrayBinaryNode(_n);
        }
    }
};

void PostorderTraverse(BinaryNode& CurrentNode)
{
    if (CurrentNode._Left != nullptr) PostorderTraverse(*CurrentNode._Left);
    if (CurrentNode._Right != nullptr) PostorderTraverse(*CurrentNode._Right);
    cout << CurrentNode._Num << "\n";
}


int main()
{
    ios_base::sync_with_stdio(false);
    cin.tie(NULL);
    cout.tie(NULL);

    int _N;
    cin >> _N;
    BinaryNode _RootNode(_N);
    while (true) {
        cin >> _N;
        if (cin.eof() == true)
            break;
        _RootNode.ArrayBinaryNode(_N);
    }

    PostorderTraverse(_RootNode);

	return 0;
}

“백준 5639번 (이진 검색 트리, C++) [BAEKJOON]”에 대한 1,493개의 생각

  1. https://open.substack.com/pub/ricardoljzk663/p/why-samahan-tea-should-be-in-every

    Hey everyone!

    I wanted to take a moment to share my experience with Samahan and its amazing herbal tea. I first discovered Samahan a few years ago when I was feeling under the weather. A friend recommended it, and I was curious to give it a try.

    Samahan is an herbal blend from Sri Lanka, known for its unique combination of spices and herbs. The first time I brewed a cup, I was hit with this warm, comforting aroma that immediately made me feel better. It contains a mix of ingredients like ginger, cinnamon, and pepper, which not only taste great but also have soothing properties.

    What I love most about Samahan tea is its versatility. I drink it when I’m feeling sick, but I also enjoy it as a cozy drink on chilly evenings. It has a bit of spice, which gives it a kick that really warms you up from the inside. Plus, it’s caffeine-free, so I can enjoy it anytime without worrying about staying up too late.

    Another benefit I’ve noticed is its ability to help with digestion. After a heavy meal, sipping on Samahan really helps settle my stomach. It feels like a natural remedy that just works, and I appreciate that it’s made from all-natural ingredients.

    Overall, I highly recommend giving Samahan tea a try. Whether you’re looking for a soothing drink when you’re under the weather or just want something warm and comforting, it’s definitely worth it. It’s become a staple in my pantry, and I can’t imagine my routine without it. Have any of you tried it? I’d love to hear your thoughts!

  2. https://messiaheitp499.mystrikingly.com/

    Hey everyone!

    I wanted to take a moment to share my experience with Samahan and its amazing herbal tea. I first discovered Samahan a few years ago when I was feeling under the weather. A friend recommended it, and I was curious to give it a try.

    Samahan is an herbal blend from Sri Lanka, known for its unique combination of spices and herbs. The first time I brewed a cup, I was hit with this warm, comforting aroma that immediately made me feel better. It contains a mix of ingredients like ginger, cinnamon, and pepper, which not only taste great but also have soothing properties.

    What I love most about Samahan tea is its versatility. I drink it when I’m feeling sick, but I also enjoy it as a cozy drink on chilly evenings. It has a bit of spice, which gives it a kick that really warms you up from the inside. Plus, it’s caffeine-free, so I can enjoy it anytime without worrying about staying up too late.

    Another benefit I’ve noticed is its ability to help with digestion. After a heavy meal, sipping on Samahan really helps settle my stomach. It feels like a natural remedy that just works, and I appreciate that it’s made from all-natural ingredients.

    Overall, I highly recommend giving Samahan tea a try. Whether you’re looking for a soothing drink when you’re under the weather or just want something warm and comforting, it’s definitely worth it. It’s become a staple in my pantry, and I can’t imagine my routine without it. Have any of you tried it? I’d love to hear your thoughts!

  3. Продвижение раскрутка сайта представляет собой комплекс мер, направленных на повышение видимости веб-ресурса в поисковых системах, таких как Google и Яндекс. Главная цель SEO продвижения — привлечь целевой трафик, увеличивая количество посетителей, а следовательно, и потенциальных клиентов. Для достижения существенных результатов, необходимо уделить внимание как внутренней, так и внешней оптимизации. Внутренняя оптимизация включает в себя разработку качественного контента, использование релевантных ключевых слов, оптимизацию метатегов, правильную структуру URL, улучшение навигации и скорости загрузки страниц. Контент играет ключевую роль — он должен быть уникальным, информативным и соответствующим запросам пользователей. Внешняя оптимизация связана с наращиванием ссылочной массы: получение качественных обратных ссылок с авторитетных ресурсов повышает доверие поисковых систем и улучшает позиции сайта. Социальные сигналы, использование SMM и контент-маркетинга также способствуют улучшению видимости сайта. Важно регулярно анализировать результаты продвижения, проводя аудит сайта, следить за изменениями алгоритмов поисковых систем и адаптироваться под новые требования. Таким образом, продвижение раскрутка сайта требует комплексного и системного подхода, тщательного планирования и постоянного мониторинга результатов для достижения устойчивого успеха в конкурентной онлайн-среде.

    Источник

댓글 달기

이메일 주소는 공개되지 않습니다. 필수 필드는 *로 표시됩니다

위로 스크롤