문자와 문자열
https://www.acmicpc.net/problem/27866
시간 제한 | 메모리 제한 | 제출 | 정답 | 맞힌 사람 | 정답 비율 |
---|---|---|---|---|---|
1 초 | 1024 MB | 5761 | 3972 | 3653 | 71.042% |
문제
단어 S와 정수 i가 주어졌을 때,
S의 i번째 글자를 출력하는 프로그램을 작성하시오.
입력
첫째 줄에 영어 소문자와 대문자로만 이루어진 단어 S가 주어진다.
단어의 길이는 최대 1,000이다.
둘째 줄에 정수 i가 주어진다. ( 1 ≤ i ≤ |S| )
출력
S의 i번째 글자를 출력한다.
예제 입력 1
Sprout
3
Sprout
3
Sprout 3
예제 출력 1
r
r
r
예제 입력 2
shiftpsh
6
shiftpsh
6
shiftpsh 6
예제 출력 2
p
p
p
예제 입력 3
Baekjoon
4
Baekjoon
4
Baekjoon 4
예제 출력 3
k
k
k
노트
문자열 S에 대해 |S|는 S의 길이를 의미한다.
출처
- 문제를 검수한 사람: jh05013, kiwiyou, tlsdydaud1, wider93
- 문제를 만든 사람: shiftpsh
알고리즘 분류
통과된 코드
#include <iostream>
using namespace std;
int main()
{
string str;
int n;
cin >> str >> n;
cout << str[n - 1]; // 인덱스를 넘어가면 문제 오류
return 0;
}
#include <iostream>
using namespace std;
int main()
{
string str;
int n;
cin >> str >> n;
cout << str[n - 1]; // 인덱스를 넘어가면 문제 오류
return 0;
}
#include <iostream> using namespace std; int main() { string str; int n; cin >> str >> n; cout << str[n - 1]; // 인덱스를 넘어가면 문제 오류 return 0; }